26 January 2010

Quick Test Professional Automation with Adobe PDF Documents - I

Prerequisites - 

Full version installation of Adobe Acrobat

This is a mandatory requirement. You need to have a full version of the software installed on your system in order to have access to the Adobe API. The API only gets installed on the system with a full version of Adobe Acrobat software. If you just have adobe reader installed in your system, you cannot get the access to the Adobe API.

OLE Automation Document Object Model


The figure below shows the hierarchy of different classes in the Adobe API and how you need to proceed in order to access the objects of a specific class.

No comments:

Post a Comment